# error: script must be run on manager node

**URL:** <https://community.zeek.org/t/error-script-must-be-run-on-manager-node/1585>\
**Category:** Zeek\
**Created:** [February 16, 2010, 9:41pm UTC](https://community.zeek.org/t/error-script-must-be-run-on-manager-node/1585 "2010-02-16T21:41:42Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Tyler\_Schoenke](https://avatars.discourse-cdn.com/v4/letter/t/6de8d8/32.png) [@Tyler\_Schoenke](https://community.zeek.org/u/Tyler_Schoenke)\
**Post date:** [February 16, 2010, 9:41pm UTC](https://community.zeek.org/t/error-script-must-be-run-on-manager-node/1585/1 "2010-02-16T21:41:42Z")

</div>

I just installed Bro on Linux, CentOS 5.3 x86\_64, and am getting this  
error message when Bro tries to restart from cron. I can start Bro fine  
from the command line. Any ideas?

Content-Type: text/plain; charset=UTF-8  
Auto-Submitted: auto-generated  
X-Cron-Env: \<SHELL=/bin/sh\>  
X-Cron-Env: \<HOME=/root\>  
X-Cron-Env: \<PATH=/usr/bin:/bin\>  
X-Cron-Env: \<LOGNAME=root\>  
X-Cron-Env: \<USER=root\>

error: script must be run on manager node

Previously, I was getting this error when trying to start the cluster  
via the command line, but I fixed it by renaming the host from the FQDN  
to just the hostname without the domain extension.

On a sidenote, I switched from using the BPF filer within Bro to using  
Click! to distribute the traffic, and the eight workers are now showing  
a 6-12% drop rate down from 40-50% drop rate.

Tyler

---

<div class="post-metadata">

**Author:** ![Tyler\_Schoenke](https://avatars.discourse-cdn.com/v4/letter/t/6de8d8/32.png) [@Tyler\_Schoenke](https://community.zeek.org/u/Tyler_Schoenke)\
**Post date:** [February 16, 2010, 11:15pm UTC](https://community.zeek.org/t/error-script-must-be-run-on-manager-node/1585/2 "2010-02-16T23:15:08Z")

</div>

Never mind,

I got it working by adding /sbin and /usr/sbin to the path.

PATH=/usr/bin:/bin:/sbin:/usr/sbin  
0-59/5 \* \* \* \* /usr/local/bro/bin/broctl cron

Tyler

---

<div class="post-metadata">

**Author:** ![robin](https://yyz1.discourse-cdn.com/flex011/user_avatar/community.zeek.org/robin/32/599_2.png) [@robin](https://community.zeek.org/u/robin)\
**Post date:** [February 17, 2010, 4:25am UTC](https://community.zeek.org/t/error-script-must-be-run-on-manager-node/1585/3 "2010-02-17T04:25:05Z")

</div>

> I just installed Bro on Linux, CentOS 5.3 x86\_64, and am getting this  
> error message when Bro tries to restart from cron. I can start Bro fine  
> from the command line. Any ideas?

Hmmm ... Don't know. If you want to dig through the code, the logic  
for that is in the function isLocal() in BroControl/execute.py. It  
runs the script bin/local-interfaces to find the local IPs  
addresses.

> On a sidenote, I switched from using the BPF filer within Bro to using  
> Click! to distribute the traffic, and the eight workers are now showing  
> a 6-12% drop rate down from 40-50% drop rate.

Cool!

Robin

---

<div class="post-metadata">

**Author:** ![Justin\_Azoff](https://avatars.discourse-cdn.com/v4/letter/j/eb9ed0/32.png) [@Justin\_Azoff](https://community.zeek.org/u/Justin_Azoff)\
**Post date:** [February 17, 2010, 1:44pm UTC](https://community.zeek.org/t/error-script-must-be-run-on-manager-node/1585/4 "2010-02-17T13:44:00Z")

</div>

I fixed the same problem a while back.. The issue is that local-interfaces  
tries to run ifconfig which is not in the current PATH.

---

<div class="post-metadata">

**Author:** ![system](https://canada1.discourse-cdn.com/flex011/uploads/zeek/original/1X/f09d732bc2cc7c7cc7e35db67cf4e1d5233ce7a7.png) [@system](https://community.zeek.org/u/system)\
**Post date:** [May 6, 2022, 3:39pm UTC](https://community.zeek.org/t/error-script-must-be-run-on-manager-node/1585/5 "2022-05-06T15:39:02Z")

</div>


