Bro Installation Problem - Python/GCC

I've installed Bro 1.5.1 on a Ubuntu 9.04 machine and its working fine
however when I try to install the same version on RHEL 5 machine I'm
getting errors during compile. More specifically, it gives gcc errors
for broccoli_intern_wrap.c file. I have python/gcc etc on that machine
and I'm using shipped version of pcap [that is the only big difference
between two machines apart from OS I think]. Below is the output of make

It looks like you probably need the python-devel package. I've added
some dependencies to the Bro Wiki:

I have double-checked and python-devel package was installed. python-tools and ruby packages were missing. However even after installing those packages, I'm still getting the exact same error during make.


See the thread ending with the following link. That sounds like what
you are seeing.

I tried bro 1.4 and it installed smoothly without any hassle. I guess I
can start my work now :slight_smile: Thanks for the support!

And just for someone novice like me and who is using Bro on some
previously captured traces, you don't need to be root. Just perform
configure/make/make install steps, and then set the environment
variables as per user manual and you're good to go :slight_smile: