configure problem

Hi. I'm new to bro and my first attempt to build the app (v0.9) failed - I
couldn't get by configure. I checked the archives and another person had
the same error but it appears he solved it on his own and I couldn't tell

Briefly, I ran configure and the system can't find input file:

// ouput summary

$ ./configure
config.status: creating aux/adtrace/Makefile
config.status: error: cannot find input file: aux/adtrace/


I got the same error on 2 different operating systems: OS/X 10.3.5 and
SuSE Linux 9.1. Please let me know if you need additional information.

Thanks in advance for your help.


// detailed output


checking build system type... powerpc-apple-darwin7.5.0
checking host system type... powerpc-apple-darwin7.5.0
checking target system type... powerpc-apple-darwin7.5.0
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for OPENSSL_add_all_algorithms_conf in -lcrypto... yes
checking for SSL_new in -lssl... yes
checking whether OPENSSL_add_all_algorithms_conf is declared... yes
checking for OpenSSL >= 0.9.7... yes
checking for perl5... no
checking for perl... /usr/bin/perl
checking if we need to include arpa/nameser_compat.h... yes
checking for bison... bison -y
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for flex... flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets ${MAKE}... yes
checking for gzip... gzip
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking return type of signal handlers... void
checking for sigset... no
checking for sigaction... yes
checking for int32_t using gcc... yes
checking for u_int32_t using gcc... yes
checking for u_int16_t using gcc... yes
checking whether time.h and sys/time.h may both be included... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for memory.h... (cached) yes
checking for netinet/ip6.h... yes
checking for socklen_t... yes
checking if syslog returns int... no
checking if we should declare socket and friends... no
checking for gethostbyname... yes
checking for socket... yes
checking for putmsg in -lstr... no
checking for local pcap library... not found
checking for pcap_open_live in -lpcap... yes
checking for pcap_freecode in -lpcap... yes
checking for pcap headers... checking if pcap_compile_nopcap needs error
parameter... not needed
checking for bpf_set_bufsize... no
checking for working memcmp... yes
checking for strftime... yes
checking for strerror... yes
checking for strsep... yes
checking for mallinfo... no
checking for ns_initparse in -lresolv... no
checking for ns_initparse in resolver... yes
checking for pcap_version in libpcap... yes
checking for tgetnum in -ltermcap... yes
checking readline/readline.h usability... no
checking readline/readline.h presence... no
checking for readline/readline.h... no
checking whether byte ordering is bigendian... yes
checking for ns_msg... yes
checking for res_mkquery... yes
checking for union semun... yes
checking for struct sembuf... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating aux/cf-1.1/Makefile
config.status: creating doc/Makefile
config.status: creating doc/ref-manual/Makefile
config.status: creating doc/quick-start/Makefile
config.status: creating doc/user-manual/Makefile
config.status: creating aux/adtrace/Makefile
config.status: error: cannot find input file: aux/adtrace/


  Yeah, that was my fault, its fixed in 0.9a5 which I think will
be out real soon now :slight_smile: sorry about that.


john mcnicholas wrote:


Using the tcp analyzer (tcp.bro) on a tcpdump file collected over 30 days, I see many instances where the connection duration is '?'. I've looked at the manual, and by the definition of 'duration' I am led to believe that a ? indicates a record with an end event that never received a begin event. I'm still trying to find the calculation in the source, but does this make sense?



Yeah, that was my fault, its fixed in 0.9a5 which I think will
be out real soon now :slight_smile: sorry about that.

Have you guys also fixed the 'make install'? It refers to a non-existing .cfg.sample file.... (in 0.9a4)

ya,I have the same problem with Mike. There are many '?' duration in logs as following:
    1095308764.656004 1.809737 pop-3 3403 110 tcp 58 73 SF X
1095308766.082135 1.730581 nntp 4596 119 tcp 40 168 SF X
1095308787.021557 0.175026 other 2881 1039 tcp ? ? REJ X
1095308786.694412 0.755664 other 2880 35220 tcp ? ? REJ X
1095308787.675227 0.072789 other 2883 14977 tcp ? ? REJ X
1095308787.721514 0.172381 other 2881 1039 tcp ? ? REJ X

I want to know the mechanism how to generate the '?'.
Who can help me?

Thanks in advance. :slight_smile:


Hi Mike,

First the good news, the updated tar did fix the "./configure" problem.
(side note: there seems to be a minor incompatibility with <termcap.h> and
SUSE Linux - I'll write that up later.)

However, now I am having the same problem as Anton Chuvakin. Fortunately it
should be easy to solve.

In short, "./make install" fails because the file:
"scripts/bro.cfg.example" is missing.

I looked in the "0.8" release and the file wasn't there either; I'm guessing
it is new.

I'm not familiar enough with the product to try and create one. The quick
and dirty solution is for someone to send their copy of the file to me -
your call if it should be posted for everyone. Longer term is to update the
tar again.

Thanks for your help.


Behalf Of Anton Chuvakin, Ph.D.