Difficulties Compiling Bro on Solaris.

Trying to compile Bro-1.4 on OpenSolaris062009 I get:

-from the the configure script:

checking term.h presence… yes
configure: WARNING: term.h: present but cannot be compiled
configure: WARNING: term.h: check for missing prerequisite headers?
configure: WARNING: term.h: see the Autoconf documentation
configure: WARNING: term.h: section “Present But Cannot Be Compiled”
configure: WARNING: term.h: proceeding with the preprocessor’s result
configure: WARNING: term.h: in the future, the compiler will take precedence
configure: WARNING: ## ------------------------------------------ ##
configure: WARNING: ## Report this to the AC_PACKAGE_NAME lists. ##
configure: WARNING: ## ------------------------------------------ ##
checking for term.h… yes

from make:

gcc -g -O2 -I/usr/lib/include -I/usr/include -L/usr/lib/lib -o hf hf.o setsignal.o version.o -lz -lpcap -lpcap -lssl -lcrypto -lnsl -lsocket -lpcap -ltermcap
Undefined first referenced
symbol in file
_res hf.o (symbol belongs to implicit dependency /lib/libresolv.so.2)
ld: fatal: symbol referencing errors. No output written to hf
collect2: ld returned 1 exit status
make[4]: *** [hf] Error 1
make[4]: Leaving directory /export/home/luca/Downloads/bro-1.4/aux/hf' make[3]: *** [all-recursive] Error 1 make[3]: Leaving directory /export/home/luca/Downloads/bro-1.4/aux’
make[2]: *** [all] Error 2
make[2]: Leaving directory /export/home/luca/Downloads/bro-1.4/aux' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory /export/home/luca/Downloads/bro-1.4’
make: *** [all] Error 2

Have anyone tried to compile Bro on the same platform and got
the same issue?How to get over this? I have libncurses
from sunfreeware.com

P.S. Is it possible to convert Sun snoop dump files to libpcap format?
I tried with wireshark on Linux but there seems to have some
incompatibility between network interfaces(eth0 on Linux,rge0 on Solaris)
and wireshark refuses to convert.
Is there other way to analyze snoop format files through Bro?