Errors compiling spicy 1.1.0 under FreeBSD 13

Good morning,

When I try to compile spicy 1.1.0 under a FreeBSD 13 host, the following errors appears:

ninja: Entering directory `build'
[6/338] cd /tmp/kk/build/hilti/runtime && /usr/local/bin/python3.8 /tmp/kk/scripts/autogen-version --header /tmp/kk/build/include/hilti/rt/autogen/version.h --git-root /tmp/kk
1.1.0-branch (72d88fbc)
[291/338] Generating ../cache/spicy/precompiled_libhilti.h
FAILED: cache/spicy/precompiled_libhilti.h
cd /tmp/kk/build/hilti && /usr/local/bin/cmake -E env SPICY_CACHE=/tmp/kk/build/cache/spicy /tmp/kk/scripts/ --hilti-config /tmp/kk/build/bin/hilti-config
Abort trap
Error: could not determine location of libhilti.h
[292/338] [BISON][parser_spicy] Building parser with bison 3.7.6
ninja: build stopped: subcommand failed.
*** Error code 1


I am using the following configure options:

./configure --prefix=/opt/spicy --enable-ccache --generator=Ninja

How can I fix it?

Best regards,
C. L. Martinez

Hmm, not sure what’s going wrong there. The CI setup is building Spicy on FreeBSD 12 like this:

  1. Install dependencies through this script:
  2. Configure & build like this:

If that doesn’t work on 13, please file a ticket.



Many thanks for your help Robin.

Best regards,
C. L. Martinez