Intel Card Question

I thought I’d push this out to the group.

I’m having issues with a bunch of Intel x520 10gig cards. I install the newest ixgbe driver from the Intel page and run “modprobe -r ixgbe; modprobe allow_unsupported_sfp=1,1” but I still cannot get the cards to recognize any sfp’s. I’ve used Cisco, Intel, and others with no luck. I’ve tried a number of cables as well.

The strangest part is, after a while the server seems to stop recognizing the nic all together. I run IP link and all I get are eth0-eth3 not 4 or 5 (the 10gig card).

Anyone using these cards that would be able to assist me in getting them to recognize an sfp and show link.

I’ve tried all I can think and using copper I’m dropping packets because am mirroring 4, 1 gig ports to a single 10gig port out to my sensor.

Any thoughts/suggestions would be greatly appreciated.


We use CENTOS 7 for what that’s worth and use:

cat /etc/modprobe.d/ixgbe.conf

options ixgbe allow_unsupported_sfp=0,1 LRO=0

Using modprobe.d allows us to pass the parameters automatically on load. Alternatively, it may have been a typo but you don’t have ixgbe in your second modprobe command. I think it should be “modprobe -r ixgbe; modprobe ixgbe allow_unsupported_sfp=1,1”