Issue compiling from source on VM / Digital Ocean

I noticed this started occurring with 2.5.x. Attempting to make from source. All dependencies met and following instructions from Digital Ocean. Whether from a git clone or pulling the source files in manually, always leads to an internal compiler error. System is Ubuntu 16.04, fully updated.

Additionally, when attempting to install from the opensuse repo, there is an umet dependency error.

I recall (not confirmed) that I attempted to build from source in a KVM guest on my own machine (at Brocon) and had the exact same compiler error.

Is there a new incompatibility with virtual systems?

Repo error
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
bro : Depends: bro-core (= 2.5.1-0) but it is not going to be installed
       Depends: broctl (= 2.5.1-0) but it is not going to be installed

Compiler error

[ 86%] Building CXX object src/CMakeFiles/bro.dir/
c++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-5/README.Bugs> for instructions.
src/CMakeFiles/bro.dir/build.make:1222: recipe for target 'src/CMakeFiles/bro.dir/' failed
make[3]: *** [src/CMakeFiles/bro.dir/] Error 4
make[3]: Leaving directory '/root/bro/build'
CMakeFiles/Makefile2:828: recipe for target 'src/CMakeFiles/bro.dir/all' failed
make[2]: *** [src/CMakeFiles/bro.dir/all] Error 2
make[2]: Leaving directory '/root/bro/build'
Makefile:149: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/root/bro/build'
Makefile:15: recipe for target 'all' failed
make: *** [all] Error 2

Please be aware that if you reply directly to this particular message, your reply may not be secure. Do not use email to send us communications that contain unencrypted confidential information such as passwords, account numbers or Social Security numbers. If you must provide this type of information, please visit to submit a secure form using any of the ”Contact Us” forms. In addition, you should not send via email any inquiry or request that may be time sensitive. The information in this e-mail is confidential. It is intended for the individual or entity to whom it is addressed. If you have received this email in error, please destroy or delete the message and advise the sender of the error by return email.

For the repo error (which I assume is when trying to install binary
packages, not when trying to install from source) - could you give the
exact steps that you perform to get that error (in the optimal case all
commands starting from a clean installation).

For the compilation error - is there a chance that your VM is running out
of memory?


Update: Does NOT occur with same source package, same dependencies, using Ubuntu 14.04

The repo method was as described here: (Ubuntu 16.04)

It was newly provisioned VPS with Digital Ocean, running no other utilities at the time. It's unlikely it was running out of memory, but I destroyed it soon after I spun up Ubuntu 14.04 to test. As I mentioned, building from source the same exact way on Ubuntu 14.04 did not have the compiler error. I didn't try and install from repo on 14.04.

I destroyed that VM again and repeated the package install on Ubuntu 14.04, the method worked with no issues seen in 16.04.

Hi Brad,

I sadly cannot reproduce this. I used a Ubuntu 16.04.03 x64 on Ubuntu
($20/mo standard instance).

The binary installation worked flawlessly - asciinema recording of the
whole process starting with a fresh VM at

Similarly compiling the bro 2.5.1 source did not yield any problems during

If you can still see this, please give exact step-by-step instructions on
how to reproduce your problems and I will try to look into it.

Thanks a lot,