minimum required version of python?

Do we require a minimum version of Python in order to use Bro?

For example, I've noticed various uses of conditional expressions
(true_value if condition else false_value) in the code (this
feature was introduced in Python 2.5), and since RHEL5 has Python 2.4,
then Bro (or at least the parts that rely on Python) won't work on RHEL5.

I was able to build Bro on a RHEL5 machine without (apparently)
any errors, but when I try to run broctl, it fails with this message:

SyntaxError: invalid syntax

The only place where I can see any mention of a minimum required
version of Python is in the broctl README, where it says Python >= 2.4
is required.


For BroControl it used to be 2.4 but that's apparently not the case
anymore if there are 2.5 constructs in there now. If it's easy to
eliminate things that prevent it from running with 2.4, we could do
that; but on the other hand I'm tempted to just say we require at
least 2.6. That's not exactly new anymore, and if people can't find
packages, it's actually straight-forward to compile from source (I've
done it many times :slight_smile:


That sounds best to me.