fatal error: can't find base/init-bare.bro


I’ve compiled bro from source to do some debugging. Once compiled I can’t run bro since there is an error popping up:

default@debian:~/bro$ ./build/src/bro
fatal error: can’t find base/init-bare.bro

If I do the make install and then call bro from /usr/local/bro/bin/bro it works fine.

What I should do to execute bro from the build directory?


source build/bro-path-dev.sh

should set all required environment variables.


Easy one!


It actually works if i’m in a shell but not if I’m debugging it with dbg.
It still shows the same error when executing main.cc:759 → add_input_file(“base/init-bare.bro”);

Is there anything I need to execute from within dbg to set the environment variables while using gdb?

Thank you again

I’ve tried running:

set exec-wrapper bash -c 'source /home/default/bro/build/bro-path-dev.sh'

no. How exactly are you running gdb?

source build/bro-path-dev.sh
gdb `which bro`

should work just fine.

I’m doing:

gdb --interpreter mi --args “/home/default/bro/build/src/bro” -r /tmp/arp_l2tpv3.cap

I’m using VisualGDB (http://visualgdb.com/?features=linux) to debug it from Visual Studio as I’ve done with tons of other projects. It just execute the gdb commands over SSH So its basically the same than executing them from a ssh session.