site-report.pl

Because the installed perl was older than required when a colleague
installed BRO, the scripts did not go in correctly. After a bit of
fiddling with the system I finally appear to have gotten everything
taken care of but the site-report.pl script. The script itself
appears to run, however all I get is an email that says:

report-range + report-start exceeds the current time
exiting program

Does anyone know if there is an easy way of fixing this? I already
tried reinstalling the script from the src tree (it was necessary to
get it running after upgrading perl).

Thank you,

John

- ----------------------------------------------------------------------
- ---
John Ives
GSEC, GCIH, GCWN
System & Network Security
University of California, Berkeley

Phone (510) 642-7773
Cell (510) 229-8676
- ----------------------------------------------------------------------
- ---

Is the problem seen when running it manually? from cron?
the script usually complains like this when the total time range asked
for extends beyond the current time.

        Roger Winslow

John Ives wrote:

The error message is only received if the script is run out of
cron. If I run it manually, I don't get anything though there is a
rpt file generated, however, it only has the connection log summary.

Thanks,

John

Is the problem seen when running it manually? from cron?
the script usually complains like this when the total time range
asked for extends beyond the current time.

        Roger Winslow

John Ives wrote:

> Because the installed perl was older than required when a
> colleague installed BRO, the scripts did not go in correctly.
> After a bit of fiddling with the system I finally appear to have
> gotten everything taken care of but the site-report.pl script.
> The script itself appears to run, however all I get is an email
> that says:
>
> report-range + report-start exceeds the current time
> exiting program
>
> Does anyone know if there is an easy way of fixing this? I
> already tried reinstalling the script from the src tree (it was
> necessary to get it running after upgrading perl).
>
> Thank you,
>
> John
>
>
> ------------------------------------------------------------------
> ---- ---
> John Ives
> GSEC, GCIH, GCWN
> System & Network Security
> University of California, Berkeley
>
> Phone (510) 642-7773
> Cell (510) 229-8676
> ------------------------------------------------------------------
> ---- ---
>

_______________________________________________
Bro mailing list
bro@bro-ids.org
http://mailman.ICSI.Berkeley.EDU/mailman/listinfo/bro

- ----------------------------------------------------------------------
- ---
John Ives
GSEC, GCIH, GCWN
System & Network Security
University of California, Berkeley

Phone (510) 642-7773
Cell (510) 229-8676
- ----------------------------------------------------------------------
- ---