Host Key Verification Failed

Hello there,

I’ve tried to install Bro on a Ubuntu 16.04 virtual machine (VirtualBox) with following guide:

After the installation, I started broctl and tryped “install”, but I reveiced an error message:

Host key verification failed.
Error: cannot create (some of the) directories /usr/local/bro,/usr/local/bro/logs,/usr/local/bro/spool,/usr/local/bro/spool/tmp on node bro

I want to run Bro on a single machine (so no cluster at all), I checked the node.cfg, it looks like this:


Of course I installed a SSH Server (apt-get install openssh-server), and successfully connected to my VM with several divices.

There was a common problem in this Mailing-List, but unfortunatly it remaind unsolved...


I'm new to linux and bro, also, english is not my native language, so please forgive me my faults. :)

I would be glad to hear from you guys!

Thanks alot!


Could you try running this command:
LANG=C broctl install

Let me know if that works or not.

Hey Daniel,

well it worked. I was able to submit the command "install", "start" and "stop", but everytime with LANG=C. How can I avoid that I have to type in LANG=C all the time?

Could you explain me what I did wrong or what the command "LANG=C" does? Thanks alot. :slight_smile:


BroControl runs the "ifconfig" command, and then tries to read IP
addresses from the output. This might fail depending on which locale
your system is configured to use. Here are two simple workarounds:

1) create a shell script wrapper that sets LANG and runs broctl, or
2) patch the broctl source to set LANG when it runs ifconfig (to do
this, edit $PREFIX/lib/broctl/BroControl/, where $PREFIX
is your bro install prefix directory, and then look for PATH, and add
LANG=C right before the PATH=...)

These workarounds won't be needed for the next Bro release.