Installation of Spicy on Ubuntu 22.04

Hello all, I am new to this platform, and I am trying to install spicy on ubuntu 22.04. running dpkg --install spicy.deb has been giving me the error of no directory.
please, I need the repository name or installation guide as i want to do a project that will require me to work with spicy.


Unfortunately Spicy currently provides no standalone packages for ubuntu-22.04.

You do not say whether you plan to use Spicy together with Zeek or as a standalone parser. If you plan to use Spicy with Zeek Zeek’s binary packages or Docker images should come with Spicy.

If you plan to use Spicy standalone you would need to build Spicy from source.

Reading package lists… Donesha256:4ef74dd2ac2b1346e3c70964a3a6ef02b33244b60fb9f3eb0c675b4c99f92752
Status: Image is up to date for zeek/zeek:lts
femi@femi-VirtualBox:~$ docker run --name my_zeek -it zeek/zeek:lts /bin/bash
root@f2797a8f8686:/# docker run --name my_zeek -it zeek/zeek:lts /bin/bash
bash: docker: command not found
root@f2797a8f8686:/# docker run
bash: docker: command not found

This is the error i have in the docker container

You hadn’t mentioned previously that you were already running this in a Docker container, could you share what container you are using? If you are open to it, you could just use the Zeek container directly instead of running it in Docker.

I have discontinued the installation on ubuntu and i want to do it on windows now.
Can Zeek-LTS be installed on windows through desktop container? Please

Hi all, I have installed Zeek successfully using a container. i am having some challenges.
I want the zeek to be able to analyze protocols and elements of exhanged messages in saved pcapng file.
The pcapng files are traffic generated from wireshark.
I have executed zeek -r commands with bash, from home with no success so far with my zeek.
I need help in using the zeek to analyse this pcapng files.
i have also tried cd spicy and tried to use spicy with no success.

can someone help me please.